最近遇到几位刚入手BeTheme和Avada主题的同学,在启动主题环节出的问题,后来发现都与主机有关。特意整理出一篇关于WordPress、Avada主题、BeTheme主题官方对于主机支持的信息,供大家参考。后面还有一些我的使用心得。

先看WordPress的需求

网址来源:https://wordpress.org/about/requirements/

运行 WordPress 我们推荐您的主机支持:

  • PHP 7 或更高
  • MySQL 5.6 起步 或者 MariaDB 10.0 起步
  • HTTPS 支持
  • 推荐 Apache 或者 Nginx运行 WordPress,其他支持 PHP 和 MySQL 的也可以。
  • 注意:WordPress也可以工作在老版本的 PHP 或 MySQL上,比如PHP 5.2.4+ 和MySQL 5.0+,但这些版本已正式结束,可能让你的网站有安全漏洞。

 

Avada官方对环境的要求

  • WordPress 4.6 或更高
  • PHP 5.6 或更高
  • MySQL 5.6 或更高
  • 虽然也可以在老版本的 PHP 5.3.x 上运行,但建议至少 PHP 5.6,最好是 PHP 7.0,WordPress 也推荐 PHP 7

 

Avada推荐的主机

  • WP Engine 或者 Blue Host (英文网站的https://www.bluehost.com/special/wordpress)

 

BeTheme官方推荐的主机

  • 小鳄鱼 HostGator(hostgator.com)

 

我的感受

  • 这两个Avada和BeTheme主题我都在阿里云的298元主机上运行安装过,虽然环境配置较低,但目前可以用,详见我的安装视频。
  • 英文站的Bluehost也使用过,运行Avada很流畅,有的同学说运行BeTheme出问题
  • godaddy,有很多人说运行容易出问题,特别是Avada主题
  • 西部数码,我用过一个客户购买的,需要提交工单打开一些功能,自己做一些设置,后来正常使用BeTheme。
  • 很多使用Win主机的同学,问题多多,毕竟不是原生PHP环境
  • 有一些使用阿里云ECS服务器的同学,自己不太会配置环境,Avada导入经常出问题,可以使用手动导入。方法在Avada教程中讲过。
  • 有的主机不支持重定向,造成很多404错误,解决方法具体问题具体分析

发表回复

请填写评论
请填写您的名字